[Calypso] [PATCH] setup.py: fix test requirements

Guido G√ľnther agx at sigxcpu.org
Sun Apr 10 03:49:42 PDT 2016


It's tests_require not test_requires, fixes:

 python setup.py clean -a
 /usr/lib/python2.7/distutils/dist.py:267: UserWarning: Unknown distribution option: 'test_requires'
---
 setup.py | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/setup.py b/setup.py
index 56db8fc..3347920 100755
--- a/setup.py
+++ b/setup.py
@@ -78,7 +78,7 @@ setup(
     packages=["calypso", "calypso.acl"],
     provides=["calypso"],
     install_requires=["daemon","vobject"],
-    test_requires=['nose>=0.11.1'],
+    tests_require=['nose>=0.11.1'],
     scripts=["calypso.py"],
     cmdclass={"build_scripts": BuildScripts},
     keywords=["calendar", "CalDAV"],
-- 
2.8.0.rc3


More information about the Calypso mailing list