[Snek] [keith-packard/snek] 64cec1: Move value checking to pool_offset and pool_addr

Keith Packard noreply at github.com
Sat Feb 16 12:16:25 PST 2019


  Branch: refs/heads/master
  Home:   https://github.com/keith-packard/snek
  Commit: 64cec135ed6537087f954daa7328701f09976bda
      https://github.com/keith-packard/snek/commit/64cec135ed6537087f954daa7328701f09976bda
  Author: Keith Packard <keithp at keithp.com>
  Date:   2019-02-16 (Sat, 16 Feb 2019)

  Changed paths:
    M snek-memory.c

  Log Message:
  -----------
  Move value checking to pool_offset and pool_addr

This makes sure that all pool reference transforms go through all
checks under SNEK_DEBUG mode.

Signed-off-by: Keith Packard <keithp at keithp.com>


  Commit: 4770a1385485a4ffd22d5c57d35f82d86f75a2d2
      https://github.com/keith-packard/snek/commit/4770a1385485a4ffd22d5c57d35f82d86f75a2d2
  Author: Keith Packard <keithp at keithp.com>
  Date:   2019-02-16 (Sat, 16 Feb 2019)

  Changed paths:
    M snek-code.c
    M snek-frame.c
    M snek-list.c
    M snek-memory.c
    M snek-name.c
    M snek-print.c
    M snek.h
    M snekde/snekde.py

  Log Message:
  -----------
  Rename snek_pool_ref to snek_pool_addr

This makes the naming more consistent with the internal pool_addr
function and many of the uses where the return was called 'addr' of
some sort.

Signed-off-by: Keith Packard <keithp at keithp.com>


  Commit: 7e07df217206be0578abfdd59065be6e640167e1
      https://github.com/keith-packard/snek/commit/7e07df217206be0578abfdd59065be6e640167e1
  Author: Keith Packard <keithp at keithp.com>
  Date:   2019-02-16 (Sat, 16 Feb 2019)

  Changed paths:
    M snekde/snekde.py

  Log Message:
  -----------
  snekde: Reset serial timeout under try block in case that fails

If the serial device has failed, resetting the timeout will
fail. Place that under the try block so that exceptions will be
ignored.

Also use 'with' statements for more locking so that exceptions will
cause the lock to be released, allowing the user to exit cleanly with
F4.

Signed-off-by: Keith Packard <keithp at keithp.com>


Compare: https://github.com/keith-packard/snek/compare/dd9a44bfddfb...7e07df217206


More information about the Snek mailing list