[Nickle] BigInteger bug

Michel Salim michel.salim at gmail.com
Wed Mar 1 20:59:47 PST 2006

Hi Bart,

On 2/28/06, Bart Massey <bart at po8.org> wrote:
> Interesting bug report!  This is one of the uglier Nickle
> bugs in quite a long time.
> Unfortunately, I can't reproduce the bug from CVS head.
> Also, I tried building CVS head from scratch on my home
> Linux box, and it seems to build fine.
> I'm afraid we'll need a bit more information so we can track
> down and solve your problem.  Exactly what version of the
> Nickle source were you using, obtained from where?  What
> operating system?  What CPU?  What specific build problem
> did you have? Can you supply a script that will reproduce
> the bug reliably?  In particular, is the invocation of fib()
> necessary, or does just typing in the last sum fail (I'd
> expect the latter)?
Nickle 2.53, from the release directory on the website, compiled on
Fedora Core 5 test 3 (gcc-4.1.0-1) on both i386 and x86_64. And yes,
just adding the two numbers together fail.

Compiling from CVS failed for me with the following (I just tried
updating again and no updates were pulled, perhaps the read-only tree
is not in sync?)

gram.c:14: warning: function declaration isn't a prototype
gram.c:2931: warning: function declaration isn't a prototype
flex   lex.l
"lex.l", line 362: bad character:
"lex.l", line 362: missing quote
"lex.l", line 366: missing quote
"lex.l", line 369: missing quote
"lex.l", line 373: missing quote
"lex.l", line 853: EOF encountered inside an action
make[2]: *** [lex.c] Error 1
make[2]: Leaving directory `/home/michel/src/nickle'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/michel/src/nickle'
make: *** [all] Error 2

> Let us know and we'll track this down and fix it for you.
>     Bart
> P.S.---BTW, it's not terribly relevant and I'm sure you know this,
> but the normal way to code what you were doing would be to
> use nested functions to hide the utility function fibh()...
Certainly! I wanted to see if calling fibh directly does not reproduce
the bug (but since even adding the two numbers fail ..)

I'll try tomorrow on my office computer, I have a feeling it might be
something triggered by GCC 4.1 ..


Michel Salim

More information about the Nickle mailing list