[Nickle] New Nickle cosmetic feature
Bart Massey
bart at cs.pdx.edu
Thu May 20 02:52:44 PDT 2004
A common C idiom is to use the value of a for() loop index
"off-the-end":
int x = 0;
for (; x < 5; x++)
foo(x);
for (; x < 10; x++)
bar(x);
That extra leading semicolon has always driven me nuts.
It is now optional. IMHO this is much easier to read
int x = 0;
for (x < 5; x++)
foo(x);
for (x < 10; x++)
bar(x);
so I hacked the grammar etc to fix it.
Have fun!
Bart
More information about the Nickle
mailing list